Uploaded image for project: 'FreePBX'
  1. FreePBX
  2. FREEPBX-21812

Certman v15.0.28 introduced few new issues compared to previous version.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 15
    • Fix Version/s: 15
    • Component/s: None
    • Labels:
      None
    • Bug Tracker:
      QA Testing
    • ToDo:
    • Module Fix Version:

      Description

      Functionality of lecertificate for adding the lerules to firewall with certman v15.0.28 got changed and Im seeing below mentioned issues.
      1. If user is not using http port 80 then the certificate generation or update fails with new version and user is forced to use a http port 80.

      
      [root@~]# fwconsole certificates  --updateall --force
      force update enabled !!!
      Certificate named "default" is going to expire in less than a month. Please update this certificate in Certificate Manager
      There was an error updating certificate "mydepid.deployments.pbxact.com": Error 'Requested 'http://mydepid.deployments.pbxact.com//.freepbx-known/e5de1be1cae1819e66cd23609f9ef454' - Failed connect to mydepid.deployments.pbxact.com:80; Connection refused' when requesting http://mydepid.deployments.pbxact.com//.freepbx-known/e5de1be1cae1819e66cd23609f9ef454
      [root@~]# 

      2. The letsencrypt firewall rules is hardcoded and will be enabled always and user has no option to remove these rules.
      3. lerule enable/disable option from GUI/CLI is not working anymore.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                psandesh Sandesh Prakash
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  NextupJiraPlusStatus

                  Error rendering 'slack.nextup.jira:nextup-jira-plus-status'. Please contact your Jira administrators.