Uploaded image for project: 'FreePBX'
  1. FreePBX
  2. FREEPBX-916

Cisco 7960 (and probably 7940) support paging

    Details

    • Type: Feature Requests
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Paging & Intercom
    • Labels:
      None

      Description

      The Paging and Intercom section only mentions the GXP-2000 phone; the Cisco 7960 (and most likely the 7940) works if auto answer is manually selected on the phone (Settings, Call Preferences, Auto Answer (Intercom), Line n ON). Either the main extension can be set to auto answer, or the phone can have 2 extensions
      - the regular one, and a second one with auto answer enabled, which is adding to the paging group.

        Attachments

          Activity

          georgesteinmetz George Steinmetz added a comment -

          PS: The above was included so it could be added to Paging and Intercom's opening paragraph, which currently states: "This module is for specific phones that are capable of Paging or Intercom. Presently, Intercom is not supported, only group paging is. The current list of supported phones is GXP-2000 with firmware 1.0.13 or higher, Snom phones with 'recent' firmware, and a few various other phones."

          mjh001 mjh001 added a comment -

          I have tested with the 7940 and confirmed it works as well.

          gregmac gregmac added a comment -

          Can you try this with current SVN (specifically, the change in http://www.freepbx.org/trac/changeset/2057)?

          Basically it changes the call-info header from:

          Call-info: auto-answer=0

          to

          Call-info: \;auto-answer=0

          According to http://www.voip-info.org/wiki/view/Script+to+page+mixed+SIP+%252F+SCCP+system it looks like it should work with Cisco phones.

          georgesteinmetz George Steinmetz added a comment -

          I tested with 2080 on a Cisco 7960 with SIP firmware version 8.2; it rang twice (2 2-second rings without the normal 4-second pause between rings), then dropped a few seconds later. When I set the Cisco phone to auto answer, it worked fine. (I normally have 2 extensions on the phone; line 1 is normal, line 2 is another extension, defined in freePBX as part of the paging group, and defined on the phone to auto answer.)

          gregmac gregmac added a comment -

          No more feedback
          - I assume this works?


            People

            • Assignee:
              gregmac gregmac
              Reporter:
              georgesteinmetz George Steinmetz
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: