FreePBX
  1. FreePBX
  2. FREEPBX-6234

Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)

    Details

    • Type: Bugs Bugs
    • Status: Closed (View Workflow)
    • Resolution: Fixed
    • Affects Version/s: 2.10
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Backend Engine:
      Asterisk 1.8
    • Backend Ver:
      1.8.20.0
    • Confirmation:
      Need Feedback
    • Distro:
      FreePBX Distro

      Description

      Noticed the issue after upgrading to asterisk 1.8.20.0.

      It looks like the issue is cosmetic as Asterisk starts and stops normally.

      Please see the messaging in various scenarios.

       
      [root@pbx asterisk]# amportal restart
       
      Please wait...
       
       
      STOPPING ASTERISK
       
      Waiting for Asterisk to Stop Gracefully...
       
      '''Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)'''
       
      Asterisk Stopped
       
       
      STOPPING FOP SERVER
       
      FOP Server Stopped
       
      SETTING FILE PERMISSIONS
       
      Permissions OK
       
      STARTING ASTERISK
       
      '''Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)'''
       
      [root@pbx asterisk]# [root@pbx bin]# [root@pbx bin]# amportal start
       
      Please wait...
       
      SETTING FILE PERMISSIONS
       
      Permissions OK
       
      STARTING ASTERISK
       
      Asterisk is already running
       
      STARTING FOP SERVER
       
      FOP server is already running
       
      [root@pbx bin]# [root@pbx bin]# amportal stop
       
      Please wait...
       
       
      STOPPING ASTERISK
       
      Waiting for Asterisk to Stop Gracefully...
       
      '''Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)'''
       
      All calls will be dropped once the timer hits 0. To cancel, press CTL-C
       
      Waiting for Asterisk to Stop 120
       
      Asterisk Stopped
       
       
      STOPPING FOP SERVER
       
      FOP Server Stopped
       
      [root@pbx bin]# amportal start
       
      Please wait...
       
      SETTING FILE PERMISSIONS
       
      Permissions OK
       
      STARTING ASTERISK
       
      '''Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)'''
       
      Asterisk Started
       
      STARTING FOP SERVER
       
      FOP Server Started

        Activity

        Andrew Nagy added a comment -
        tekach added a comment -

        I am sorry to say, but problem still exist, just as vmikhelson reported. That is in Freepbx version 2.10.1.5 and after patch.

        Andrew Nagy added a comment -

        No new framework has been pushed out since this was fixed. Please be patient.

        Andrew Nagy added a comment -

        And on that note we didn't use any of the patches listed in this ticket to fix the issue

        Andrew Nagy added a comment -

        (In http://www.freepbx.org/trac/changeset/15457) Fixes FREEPBX-6456, FREEPBX-6234 call fails on internal pickup in ring group when call confirm is enabled


          People

          • Assignee:
            Andrew Nagy
            Reporter:
            vmikhelson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development